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Introduction 

The Nozzle FleX plugin is designed to calculate stiffness and stress intensification of cylindrical 

intersections for metallic piping and vessels. The plugin has been created for use with SAP2000 

v22.1 and onwards. It may be possible to run it with earlier versions – please contact us for 

assistance. For this or any other queries, please contact support@xtrados.com. 

 

SAP2000 is a registered trademark of Computers and Structures, Inc (CSi). 

Xtrados is not affiliated with CSi. 

Applicability 

The plugin is for fabricated branches, stubs, trunnions and nozzles. The branch may be offset 

from centre of head / header (hillside nozzle), and may be angled at between 20 degrees and 

90 degrees from the cylinder longitudinal axis. The intersection may have a reinforcing ring of 

constant width. 

 

The following characteristics and limitations apply 

• intersection of two cylinders, or cylinder and head 

• each has constant thickness 

• the intersection does not have a radius of curvature (such as a sweepolet or welding tee) 

• material is isotropic 

• circular reinforcement pad or no reinforcement 

 

Therefore the plug-in does not currently cater to  

• welding tee fittings 

• extruded tees 

• trunnions on elbows 

• branch on reducer or conical shell 

• not recommended for tank nozzles near tank bottom (use API 650 Appendix P). 

 

 

  

mailto:support@xtrados.com
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Installation 

This is a self-extracting executable zip file - save this to My Docs or any folder of your choosing, 

then double click to unzip it. This creates a folder called 'Nozzle_flex' containing the plugin files. 

Note: thanks to Windows' paternal instincts, you may need to Unblock the file first - right click on 

Nozzle_flex.exe, choose 'Properties', tick 'Unblock' and OK. Any troubles, please contact your 

IT support. 

 

Install the plug-in by first choosing Tools -> Add/Show Plugins from the SAP2000 main menu. 

Browse to where you unzipped the plugin, select the file 'SAP2000Plugin_Xtrados_Nozzle.dll', 

then 'Add' and 'OK'. If successful the plugin will now be available directly under 'Tools'. 

Trial license 

On start-up, you will need to license the plugin. Email us to receive a trial license. Save this 

license file somewhere easy to find. In the first dialog box, click on 'Enter license'. 

 

 
 

Next, choose 'Load license from file' and browse to the license file. Then click on ‘Register’. 

 
The plug-in trial should now be ready to go. Each time you re-start it you just click on the 

‘Continue’ button in the first dialog.  

mailto:support@xtrados.com
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Licensing the plug-in 

If you or your organisation has purchased a license, click on 'Enter license' in the first dialog. 

Then click on the gear wheel icon, followed by ‘Copy HWID’. 

Paste the license key into an email and email to us – we will send your license key by return 

email. 

If you’re obtaining licenses for multiple users, please either supply us with the relevant email 

addresses, or have your users email their HWID codes to you for collation. 

 

 
 

We will email your license key back – save this key to a place you can easily find. Select ‘Load 

license from file’ in the above dialog box, and browse to the license file. Then click on ‘Register’. 

 

In some cases, an update to the plug-in version will require a new license file. In this case we 

will email new license keys if your license is current. 

  

mailto:support@xtrados.com
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Finite element model 

The finite element model uses SAP2000’s thick shell elements. This is a 4-node shell element, 

which includes membrane and bending stiffness, thick shell / transverse shear displacements, 

quadratic in-plane displacement and 'drilling' rotational effects. In other words, it's accuracy is 

good even when compared to typical 8-noded quadratic elements. 

 

Note that the shell is modelled at the centre of the pipe wall. Therefore dimensions in the model 

do not coincide with the outer radius of pipe. Reinforcing pad widths are increased by half the 

branch thickness to compensate for this. 

 

Orientation of local axes 

When referring to nozzle flexibility, we are talking about the stiffness of the header (or vessel / 

tank) at the point of nozzle attachment. NozzleFlex calculates the following rotational and 

translational stiffnesses - 

• Rotational stiffness calculated in three orthogonal axes 

• Translational stiffness calculated in radial direction. Stiffness in the other two (shear) 

directions are not calculated (considered to be rigid). 

The orientation of these axes is as descibed below. 

Cylindrical intersections 

Refer to Figure 1a. A right-angled co-ordinate system is defined at the intersection of the shell 

and the nozzle centreline. The local coordinate system axes are : 

 

1. Radial to shell. Radial displacement occurs along this axis. Torsional rotation occurs 

about this axis. Often called Axial direction. However note that this direction is defined 

with respect to the shell, not the branch. 

2. Tangential to shell. Longitudinal rotation (aka in-plane) occurs about this axis. 

3. Longitudinal (parallel to shell centreline axis). Circumferential rotation (aka out of plane 

or out-plane) occurs about this axis. 
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Figure 1a - Branch with hillside offset. Note: standout dimension ‘l’ is measured along the branch axis, as shown in 

figure 1b. For the model in Figure 1, branch angle ‘alpha’ is 90 degrees so l.sin alpha is equal to l. If the branch has a 

flange or other feature which stiffens it, do not include this length in the standout. 

 

The plug-in takes the Branch Standout as an input. If you have dimension L instead, branch 

standout can be calculated as follows: 

 

𝑙 =  
𝐿 −  √𝑅2 − 𝑥𝑜

2

sin 𝛼
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Figure 1b – elevation view of intersection 

 

Rigid ends (1) and (2) are locations at which the shell / header is assumed to be rigid in all 6 

degrees of freedom. This would coincide with the nearest flange, vacuum ring, head, large 

welded support or other feature which significantly stiffens the shell. 

 

When the branch angle is 90°, the lengths to rigid ends (1) and (2) are the (positive) distances 

from the centre of the branch. For branch angles of less than 90°, these are measured with 

respect to the theoretical branch centreline / shell intersection at zc. 

For reference, the lowest intersecting point on the branch (point with lowest Y-coordinate) 

corresponds to the mesh line with constant z-coordinate zo. These values are calculated as 

𝑧𝑜 =  
√𝑟ℎ

2 − (𝑥𝑜 + 𝑟𝑏)2

tan 𝛼
 

 

𝑧𝑐 =  
√𝑟ℎ

2 − 𝑥𝑜
2

tan 𝛼
 

-where rh and rb are the header outside radius and branch outside radius respectively. 

The branch standout is measured along the branch length from the theoretical centreline 

intersection at zc. This is also the origin point for the local coordinate system seen in Figure 1a. 

Nozzles on heads 

Refer to Figure 2. A right-angled co-ordinate system is defined at the intersection of the shell 

and the nozzle centreline. The local coordinate system axes are : 

 

1. Radial to shell. Radial displacement occurs along this axis. Torsional rotation occurs 

about this axis. Often called Axial direction. However note that this direction is defined 

with respect to the shell, not the branch. 

2. Tangential to shell and pointing toward centre. Circumferential rotation occurs about this 

axis. 
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3. Tangential to shell and orthogonal to axes 1 and 2. Longitudinal rotation occurs about 

this axis. 

 

Note: the designations “longitudinal” and “circumferential” are not generally used for nozzles 
on heads. We use them here just to identify which axis is being referred to. For a central 
nozzle the stiffness and SCF will be the same for both axes. 

 

 
Figure 2 – Nozzle on semi-ellipsoidal head with hillside offset. Note: branch standout is measured along the branch 

axis (dotted line). If the branch has a flange or other feature which stiffens it, do not include this length in the 

standout. 

Reinforcing pads 

The width of the reinforcing pad is measured along the curve of each mesh line going outward 

from the branch. Reinforcing pad widths are increased by half the branch thickness to 

compensate for the shell model being at the midpoint of the branch wall. 
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User interface 

Note: 

1. When the plug-in is open, SAP2000 will be non-responsive (you will get the spinning 
wheel or equivalent icon when your mouse is over the application). This is expected – 
you cannot operate SAP2000 when the plugin is open. After closing the plugin, wait 
until a dialog box from SAP2000 pops up saying ‘Plugin closed successfully’, and you 
can again use the program. 

2. When the plug-in is running an analysis, both the plug-in and SAP2000 will be non-
responsive. 

Menu Options 

Option Action or meaning 

File -> Save RTF Generate .rtf file with inputs and outputs. 
Open with any word processor software. 

File -> Close Close the plugin and return to SAP2000 

Options -> Units -> US Units Use inches, psi, lb/in, ft-lb per unit of rotation 

Options -> Units -> Metric Use mm, MPa, N/mm, Nm per unit of rotation 

Options -> Output SIF or SCF? -> SIF Generate Stress Intensification Factors for 
pipe stress analysis. Incorporates the user-
entered weld SCF (aka Fatigue Strength 
Reduction Factor) to incorporate the effect of 
imperfections at the toe of the weld. Note that 
SCF and SIF are related as follows: 
SIF = 0.5*SCF* (weld SCF) 

Options -> Output SIF or SCF? -> SCF Generate Stress Concentration Factors for 
use in a separate vessel local stress analysis. 
Does not include weld SCF (this can be 
applied in the separate analysis). 
Currently the plugin outputs the SCF for 
membrane plus bending only. 

Options -> Rotation -> Degrees Generate rotational stiffnesses per degree 

Options -> Rotation -> Rotations Generate rotational stiffnesses per radian 

Options -> About General information about the plugin 

Options -> Help Open the help file (this document) 

Options -> License Show the license status and option to remove 
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Graphic User Interface - Cylinders 

 
Figure 3a – user interface (cylinders) 
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Graphic User Interface – Nozzle on Head 

 
Figure 3b – user interface (nozzle on head) 

 

There are some minor differences in the input fields for each type of head. These are explained 

in the image which appears to the right of the input window (not shown in figure 3b). You can 

show or hide the image using the arrow button [>]. 
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Modelling of Cover Weld and Re-pad 

If a covering fillet weld leg is set to greater than zero, shell element thicknesses are increased in 

the weld zone as shown below. 

 
Figure 4 – Intersection model cross-section 

 

 

Equivalent thicknesses are set to give the same areas as those in the cross-section in Figure 4. 

This gives: 

 

𝑡𝑏𝑤 =  
0.25𝑤2 + 𝑡𝑏(𝑤 + 0.5𝑡ℎ + 𝑡𝑟𝑝)

𝑤 + 0.5𝑡ℎ + 𝑡𝑟𝑝
 

 

𝑡ℎ𝑤 =  
0.25𝑤2 + 𝑤(𝑡ℎ + 𝑡𝑟𝑝) + 0.5𝑡ℎ𝑡𝑏

𝑤 + 0.5𝑡𝑏
 

 

The FEA model is not currently altered or affected by the fillet weld at re-pad edge. 

Output stiffnesses 

The plug-in calculates the branch stiffnesses using the axes shown in Figure 1. Stiffnesses are 

not calculated for bending of the header / shell itself. These stiffnesses can be used in a pipe 

stress program to model a nozzle with stiffness, or to define custom branch flexibility factors. 

Branch flexibility factors as defined in ASME B31J can be computed from rotational stiffnesses 

as follows. These equations are for angle in radian units. 
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𝑘𝑖𝑏 =
𝐸𝐼𝑏

𝐾𝑖𝑏𝑑
        𝑘𝑜𝑏 =

𝐸𝐼𝑏

𝐾𝑜𝑏𝑑
       𝑘𝑡𝑏 =

𝐸𝐼𝑏

𝐾𝑡𝑏𝑑
    

 

where: 

 

k(ib,ob,tb) is the branch flexibility factor for in-plane bending, out-of-plane bending and torsion 

respectively 

K(ib,ob,tb) is the branch rotational stiffness for in-plane bending, out-of-plane bending and 

torsion respectively. 

E is Youngs Modulus of Elasticity. 

Ib is the branch moment of inertia 

d is the branch mean diameter 

While B31J does not define an axial translation flexibility factor, one could in theory be defined 

similarly to above, using branch area Ab rather than Ib. 

You can get the flexibility factors by generating the RTF output report from the File menu. This 

report can then be opened in MS Word or Wordpad. 

How stiffness is calculated 

To avoid including the flexibility of the beam elements to which the branch attaches, the first 

model created is a simple beam model of the intersection. Subsequently a shell model of the 

intersection is created. Deflections and rotations calculated in the beam model are subtracted 

from the equivalent shell model deflections and rotations before calculating stiffnesses. 

 

Both rigid ends are fully fixed around their circumference for these calculations. 

  



Nozzle FleX Plugin for SAP2000   
 15 

Stress intensification / stress concentration factors 

The plug-in calculates factors for loads applied to the branch leg (not for loads applied to the 

vessel or header). Results are given based on the highest principal stress (for torsion we 

instead calculate the maximum shear stress). This stress may be either in the header or the 

branch – this does not affect the calculation. 

As the shell-type finite elements are located in the centre of the branch and header walls, the 

plugin ignores stresses within one half-thickness of the intersection and within the weld zone 

(the red and green areas in Figure 4). 

Stress concentration factors 

𝑖𝑖 =
2𝑆𝑖𝐼𝑏

𝑀𝑖𝐷𝑏
        𝑖𝑜 =

2𝑆𝑜𝐼𝑏

𝑀𝑜𝐷𝑏
       𝑖𝑎 =

𝑆𝑎𝐴𝑏

𝐹𝑎
      𝑖𝑡 =

2𝑆𝑡  𝐽𝑏

𝑀𝑡𝐷𝑏
 

where: 

S(i,o,a) is the maximum principal stress calculated for pure in-plane bending, out-of-plane 

bending and axial (radial)1 force respectively. 

St  is the maximum shear stress calculated for torsion 

M(i,o,t) is the applied in-plane bending moment, out-of-plane bending moment, torsion 

respectively. 

i(i,o,a,t) is the branch stress concentration factor for in-plane bending, out-of-plane bending, 

axial (radial)1 force and torsion respectively. In the plug-in these are denoted as SCF_ib, 

SCF_ob, SCF_ab and SCF_tb respectively. 

Fa is the applied axial (radial) force. 

Ib is the branch moment of inertia 

Jb is the branch polar moment of inertia, =2Ib 

Db is the branch external diameter 

Currently the plugin calculates stress concentration factors for membrane plus bending stresses 

(not membrane stresses only). 

 

Note:  
Welds are known to increase fatigue susceptibility via the creation of small imperfections and 
stress raisers. For instance, see ASME VIII Division 2 Tables 5.11 and 5.12 for values termed 
Weld Surface Fatigue Strength Reduction Factors. 
 
If analysing vessel stresses (eg in a manual calculation or spreadsheet) you would apply a 
separate factor to account for this effect as applicable. 
 

 
1 The B31 code terminology ‘axial’ is used here. Note that the SIF and stiffness calcs are with respect to 
the direction radial to the vessel or header wall at point of branch to shell intersection. This does not 
necessarily coincide with the branch axis. 
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Stress intensification factors 

Stress intensification factors as used in B31 codes are based on one half of the true stress 

concentration factor. Thus the plugin uses the following formulae to calculate the SIF’s, with 

loads applied in four separate load cases: 

 

𝑖𝑖 =
𝑆𝑖𝐼𝑏𝑘𝑤

𝑀𝑖𝐷𝑏
        𝑖𝑜 =

𝑆𝑜𝐼𝑏𝑘𝑤

𝑀𝑜𝐷𝑏
       𝑖𝑎 =

𝑆𝑎𝐴𝑏𝑘𝑤

2𝐹𝑎
      𝑖𝑡 =

𝑆𝑡  𝐽𝑏𝑘𝑤

𝑀𝑡𝐷𝑏
 

where: 

kw is the weld stress concentration factor. Welds are known to increase fatigue susceptibility 

via the creation of small imperfections and stress raisers. The FEA model does not account 

for these stress raisers. To generate a suitable SIF for use in a pipe stress program, we 

therefore include the weld stress concentration factor input field. The factor defaults to 1.35, 

which is a typical value used in industry. For additional conservatism or for vessel 

calculations you may wish to consider higher values such as those given in ASME VIII 

Division 2 Tables 5.11 and 5.12. 

other symbols – as defined in the prior section. 

In line with the physical testing methods outlined in ASME B31J, only one end of the header is 

fixed for SIF calculations on cylinders. Under the naming terminology in Figure 1b, Rigid end 2 

is fixed while Rigid end 1 is free. However, note that the cross section at the free end is still 

constrained to deform in a uniform manner, ie the end is rigid but unrestrained.  

The user can consider the effect of nearby flanges or other stiffeners on a cylindrical header by 

setting the ‘Distance to rigid end X’ as required. A rigid or stiffened section in proximity to the 

intersection on one or both sides tends to reduce stress intensification while increasing stiffness.  

When adopting the default flexible length (leaving ‘Distance to rigid end X’ blank), the end is 

generally far enough away to give conservative SIFs. To see the length values assigned in such 

cases, generate the RTF output report from the plug-in menu. 

Note that ASME B31J provides SIF formulae for cylindrical intersections which are suggested 

where the following are true: 

• Branch pipe is within 5 degrees of perpendicular to run  

• R/T<=50 

• r/t <=50 

FEA solutions such as Nozzle FleX are appropriate for intersections outside (or within) these 

parameter ranges, and can account for the effects of hillside branches, re-pad width, cover weld 

size and varying distance to rigid ends / stiffened sections. 
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Modelling in a pipe stress program 

We suggest one of the following two approaches to use the plug-in outputs in a beam-type pipe 

stress analysis program. The appropriate method may depend on the program’s capabilities. 

 

1. Model as an ASME B31J piping branch with custom flexibility factors and SIFs 

2. Model as a flexible anchor with optional SIFs 

Approach 1 – B31J pipe branch with custom flexibility factors and SIFs 

 

 
Figure 5 – B31J model with branch flexibility 

 

In this figure taken from ASME B31J (2017), spring(s) are inserted by the program at the point 

where the branch meets the header. These spring stiffnesses are normally calculated based on 

the flexibility factors given in B31J. Some pipe stress programs will let you override the flexibility 

factors. Typically these factors are available for the 3 rotational directions only.  

You can get the flexibility factors by generating the RTF output report from the plug-in menu.  

Enter only branch flexibilities – do not alter the run flexibility (unless calculated using other 

means). Assuming the stress program is using the B31J approach, the appropriate springs will 

be inserted at the branch/shell intersection point. 

If you wish to consider radial stiffness, you would also need to manually add a short link or 

internal anchor on the branch with the appropriate axial stiffness (set to rigid in all other 

directions). 

 



Nozzle FleX Plugin for SAP2000   
 18 

 
Figure 6 - Defining custom branch flexibility using CSiPlant 

 

Angled or Hillside Branches 

The plug-in calculates stiffnesses and SIFs with respect to the axes shown in figures 1a or 2. 

Therefore it is imperative that the branch be defined radially outward from the centre of header/ 

vessel to the branch intersection point. For an angled branch on a cylinder, the starting point 

along the header axis is at ‘zc’ in figure 1b.The branch should protrude slightly past the point of 

flexibility insertion (e.g. the mid or outer radius of header) before turning to the branch pipe 

orientation. Do not include a bend where the branch pipe turns at this location. 

 

 
Figure 7 -Defining branch flexibility on an angled branch (CSiPlant) 
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Figure 8 -Defining branch flexibility on an angled branch – with additional flexible link to capture radial stiffness  (CSiPlant) 

Applying the stress intensification factors – B31J style model 

Most pipe stress programs will let you specify custom stress intensification factors. Specify 

these for the branch only – do not override the header SIFs unless otherwise calculated. The 

branch SIFs are intended for use with the section modulus Z = 2Ib/Db, rather than the ‘equivalent 

section modulus’ Ze as used in past editions of ASME B31.3 and B31.1.  

 

 
User SIF entry in CSiPlant. For the ‘non-displacement’ axial SIF you can enter 0.75 times the axial SIF, or otherwise 

adjust as suggested in the B31J 2017 errata.  

 

Just as with the branch flexibilites, SIFs calculated by the plug-in are with respect to the axis 

directions in Figure 1a. Therefore hillside and angled branches should be defined as discussed 

above. 
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Approach 2 – Flexible Anchor with optional SIFs 

Under this approach, we model a rigid element from the centre of header to the midpoint of the 

shell wall at the centreline intersection. To ensure that the element is radial, it should start from 

the same axial coordinate as the centreline intersection (i.e. ‘zc’ in Fig. 1b). Examples follow for 

CSiPlant and CAESAR II. 

CSiPlant 

We created a video at the following link to show how to model a flexible nozzle in CSiPlant. 
Video tutorial - flexible nozzle in CSiPlant 

 

Note: this video was created using CSiPlant v6.2 with ASME B31.3 2018 Appendix D for 

flexibility factors. If you are defaulting to the use of ASME B31J in your model, be sure to 

override that setting for the vessel nozzle branch. Use a conventional method without flexibility 

at tees (eg ASME B31.3 Appendix D), to avoid potentially ‘doubling up’ on flexibility. 

Start by defining a flexible anchor with stiffnesses taken from the plugin outputs. Generally U1 = 

radial stiffness, R1 = torsional stiffness, R2 = circumferential bending stiffness, R3 = longitudinal 

bending stiffness. 

 
Once you’ve inserted the anchor you can inspect the axes as shown below to confirm that you 

have the directions correct. For the convention above, check that axis 1 (red) points radially 

inward or outward from the shell, axis 2 (green) points along the longitudinal axis and axis 3 

(blue) is tangential to the shell. 

https://youtu.be/uo-I8RlYRFY
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CSiPlant – line view with supports not shown. Note the small gap between joints. The flex anchor should be assigned 

to joint L-00. 
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CSiPlant – Select the flexible anchor and the joint on the pipe side, and create a support connection. 

 

 
Note that the Branch Length inside the vessel / header pipe is treated as rigid by CSiPlant. 
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Do ensure you are not using B31J for flexibility of the vessel branch, to avoid potential additional flexibility being 

added at the shell intersection. All flexibility factors should be set to 1.0 under this approach. 

 

 
CSiPlant – nozzle modelled with flexible anchor connection 

Note you can also use ‘Link elements’ to achieve a similar outcome to a flexible anchor in CSiPlant. 
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CAESAR II 

 
Example of entering stiffness values in CAESAR II 

Applying the stress intensification factors – flexible anchor model 

Most programs let you specify custom SIFs, but unless there is some way for the program to 

know what is ‘in-plane’ and what is ‘out-plane’, it must guess or make conservative 

assumptions. This may require you to model a ‘dummy intersection’ to let the program know the 

correct orientation, or you may opt to specify the larger of the in-plane and out-plane SIFs for 

both directions.  
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Example of modelling a dummy tee to correctly orient user-defined SIF’s at the shell intersection in CSiPlant 

 

Example of modelling a dummy tee to correctly orient user defined SIF’s at the shell intersection in CSiPlant (zoomed 

in view of above model). The hilited element is a connection element to connect the pipe to the flexible anchor. 
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Defining user-defined SIF’s in CSiPlant. SIF’s calculated by the plugin are Branch SIF’s not header SIF’s, so do not 

alter the header SIF entries. 

 

 

 
Entering SIFs in CAESAR II – in this example the program can’t determine correct orientations for SIF’s. A dummy 

tee can be constructed similar to that illustrated for CSiPlant above to correctly orient the SIF’s. 
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Known Issues 

Mesh for nozzles with low branch angles may need improvement. 

Version history 

Version Changes 

2.0 Added modelling of nozzle to head intersections (semi elliptical, torispherical, 
hemispherical). 
SIF calculation now uses principal stresses (max shear stress for torsional) rather 
than Von Mises. 
Option to output either SCFs or SIFs. 
Added ability to check license information. 
Explanatory image shown with each geometry type. 
Preferences for units, rotation and SCF or SIF retained after closing plugin. 

1.11 Lengths used in FE model are now given in the output RTF file. 
Fixed incorrect flexibility factors when rotational stiffnesses were based on radians. 
Fixed problem for some models in English units where certain weld zone elements 
were not being generated. 

1.10 Added option to specify covering weld SCF 
Added option to specify covering weld leg length 
Elements within weld zone have their thickness increased to account for weld size 
SIF calculation now ignores elements within weld zone 
SIF calculation now frees one end of header 
Default flexible lengths increased for both branch and header 

1.01 Fixed mesh issue with fine mesh / small nozzles / short distance to end 

1.0 First release 

  


	Introduction
	Applicability
	Installation
	Trial license
	Licensing the plug-in

	Finite element model
	Orientation of local axes
	Cylindrical intersections
	Nozzles on heads
	Reinforcing pads

	User interface
	Menu Options
	Graphic User Interface - Cylinders
	Graphic User Interface – Nozzle on Head

	Modelling of Cover Weld and Re-pad

	Output stiffnesses
	How stiffness is calculated

	Stress intensification / stress concentration factors
	Stress concentration factors
	Stress intensification factors

	Modelling in a pipe stress program
	Approach 1 – B31J pipe branch with custom flexibility factors and SIFs
	Angled or Hillside Branches
	Applying the stress intensification factors – B31J style model

	Approach 2 – Flexible Anchor with optional SIFs
	CSiPlant
	CAESAR II
	Applying the stress intensification factors – flexible anchor model

	Known Issues
	Version history

